
SRTP – Driver Version 1.02  
Doc. Revision B – November 26, 2003 
 
 

Page 1 

SRTP Communication Driver  

Communication Driver (with Specific Hosts  
from GE FANUC Manufacturer) using SRTP Protocol 

Contents 

INTRODUCTION ....................................................................................................................................................... 2 

GENERAL INFORMATION....................................................................................................................................... 3 
DEVICE CHARACTERISTICS .................................................................................................................................... 3 
LINK CHARACTERISTICS......................................................................................................................................... 3 
DRIVER CHARACTERISTICS .................................................................................................................................... 3 
CONFORMANCE TESTING ....................................................................................................................................... 4 

INSTALLING THE DRIVER ...................................................................................................................................... 5 
OTHER SOFTWARE REQUIREMENTS ....................................................................................................................... 5 

CONFIGURING THE DRIVER .................................................................................................................................. 6 
SETTING THE COMMUNICATION PARAMETERS ......................................................................................................... 6 
CONFIGURING THE DRIVER WORKSHEETS .............................................................................................................. 8 

CONFIGURING THE DEVICE ................................................................................................................................ 13 

EXECUTING THE DRIVER..................................................................................................................................... 13 

TROUBLESHOOTING ............................................................................................................................................ 14 

SAMPLE APPLICATION ........................................................................................................................................ 16 

REVISION HISTORY............................................................................................................................................... 17 
 



SRTP – Driver Version 1.02  
Doc. Revision B – November 26, 2003 
  

Page 2 

Introduction 

The SRTP driver enables communication between the Studio system (version 5.1 or higher) and some specific 
devices, manufactured by the GE FANUC Company, that implement the SRTP protocol according to the 
specifications discussed in this document.  

This document was designed to help you install, configure, and execute the SRTP driver to enable 
communication with Studio and the GE FANUC devices that implement the SRTP protocol. The information in this 
document is organized as follows: 
¾ Introduction: Provides an overview of the SRTP driver documentation. 

¾ General Information: Provides information needed to identify all the required components (hardware and 
software) used to implement communication between Studio and the SRTP driver.  

¾ Installing the Driver: Explains how to install the SRTP driver. 

¾ Configuring the Driver: Explains how to configure the communication driver.  

¾ Executing the Driver: Explains how to execute the driver to verify that you installed and configured the  
driver correctly.    

¾ Troubleshooting: Lists the most common error codes for this protocol and explains how to fix these errors. 

¾ Sample Application: Explains how to use a sample application to test the driver configuration. 

 

# Notes:  
• This document assumes that you have read the “Development Environment” chapter in the product’s 

Technical Reference Manual. 
• This document also assumes that you are familiar with the Windows NT/2000/XP environment.  

If you are unfamiliar with Windows NT/2000/XP, we suggest using the Help feature (available from the 
Windows desktop Start menu) as you work through this guide.  
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General Information 

This section explains how to identify all the hardware and software components used to implement 
communication between the SRTP driver, Studio, and other devices using the SRTP protocol.  
The information is organized into the following sections: 
� Device Characteristics 
� Link Characteristics 
� Driver Characteristics 

Device Characteristics 
This driver was tested successfully with the following devices: 
� Manufacturer: GE FANUC 
� Compatible Equipment: Series 90 PLC  
� Programming Software: LogicMaster 90 Programmer Controller Software 

For a list of the devices used for conformance testing, see “Conformance Testing” on page 4. 

Link Characteristics 
To establish communication, you must use links with the following specifications: 
� Host Communication Port: SRTP port 
� Physical Protocol: Ethernet 
� Logic Protocol: SRTP 
� Host Runtime Software: None 
� Specific PC Board: Ethernet board 
� Link Cable Scheme: Ethernet cable 

Driver Characteristics 
The SRTP driver is composed of the following files: 
� SRTP.INI: Internal driver file. You must not modify this file. 
� SRTP.MSG: Internal driver file containing error messages for each error code. You must not modify this file.  
� SRTP.PDF: Document providing detailed information about the SRTP driver. 
� SRTP.DLL: Compiled driver. 

 

# Notes:  
• All of the preceding files are installed in the /DRV subdirectory of the Studio installation directory.  
• You must use Adobe Acrobat® Reader™ (provided on the Studio installation CD-ROM) to view  

the SRTP.PDF document. 
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You can use the SRTP driver on the following operating systems:  
� Windows 9x 
� Windows 2000 
� Windows NT 
� Windows CE (x86, SH3, SH4, MIPs, ARM, or PPC) 

For a list of the operating systems used for conformance testing, see “Conformance Testing” on page 4.  
The SRTP driver supports the following registers: 
  

Register Type Length Write Read Bit Integer Float 
%I (Discrete Input) 1 Bit − • • − − 

%Q (Discrete Output) 1 Bit • • • − − 

%M (Discrete Internal) 1 Bit • • • − − 

%T (Discrete Temporary) 1 Bit • • • − − 

%AI (Analog Input) 1 Byte − • • • • 

%AQ (Analog Output) 1 Byte • • • • • 

%R (Internal Registers) 1 Byte • • • • • 

%G (Global Genius Data) 1 Bit • • • − − 
 

Â Caution: 
You can read bit values from the %AI, %AQ, and %R registers, but you cannot write bit values to 
these registers. 

 

Conformance Testing 
The following hardware/software was used for conformance testing: 
� Equipment: PLC GE FANUC 90/30 CPU 350 with CMM 321 Ethernet Interface  
� Cable: Ethernet cable 
� Operating System (development): Windows 2000 + Service Pack 2 
� Operating System (target): Windows 2000 + Service Pack 2, Windows CE v3.00 
� Studio Version: 5.1 
� Driver Version: 1.00 
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Installing the Driver 

When you install Studio version 5.1 or higher, all of the communication drivers are installed automatically.  
You must select the driver that is appropriate for the application you are using. 

Perform the following steps to select the driver from within the application: 
1. Open Studio from the Start menu.  
2.   From the Studio main menu bar, select File → Open Project to open your application. 
3.   Select Insert → Driver from the main menu bar to open the Communication Drivers dialog.  
4.   Select the SRTP driver from the Available Drivers list, and then click the Select button: 

 

Communication Drivers Dialog 

5. When the SRTP driver displays in the Selected Drivers list, click the OK button to close the dialog. 

Other Software Requirements 
You are not required to install any other software on your computer to enable communication between Studio and 
the host. However, to download the custom program to the host, you must install the LogicMaster 90 
programming software from GE FANUC. (For installation instructions, consult the documentation provided with 
the GE FANUC LogicMaster 90 software.)  
 

Â Caution: 
We strongly recommend using caution when you install the physical hardware. Consult your hardware 
manufacturer’s documentation for special instructions. 
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Configuring the Driver  

After opening Studio and selecting the SRTP driver, you must configure the driver. Configuring the SRTP driver is 
done in two parts: 
� Specifying the Communication Parameters 
� Defining communication tags and controls in the Communication tables or Driver Worksheet 

Worksheets are divided into two sections, a Header and a Body. The fields contained in these two sections 
are standard for all communications drivers — except the Station, Header, and Address fields, which are driver-
specific. This document explains how to configure the Station, Header, and Address fields only. 
 

# Note:    
For a detailed description of the Studio Standard and Main Driver Worksheets, and information about 
configuring the standard fields, review the product’s Technical Reference Manual.  

 

Setting the Communication Parameters 
Use the following steps to configure the communication parameters, which are valid for all driver worksheets 
configured in the system: 
1. From the Studio development environment, select the Comm tab located below the Workspace. 
2. Click on the Drivers folder in the Workspace to expand the folder.  
3. Right-click on the SRTP subfolder and when the pop-up menu displays, select the Settings option: 

 

Select Settings from the Pop-Up Menu 
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The SRTP: Communications Parameters dialog displays: 
 

 

SRTP: Communication Parameters Dialog 
 
4. Click the Advanced button to open the Advanced settings dialog: 
 

 
 

Advanced Settings Dialog 
 
 

Configure the parameters on this dialog as appropriate for your worksite. Consult the Studio Technical 
Reference Manual for instructions about configuring this dialog.  
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Configuring the Driver Worksheets 
This section explains how to configure the communication tags in the STANDARD and MAIN Driver Worksheets. 

Configuring the Standard Driver Worksheet 
This section explains how to configure a Standard Driver Worksheet (or communication table) to associate 
application tags with the PLC addresses. You can configure multiple Driver Worksheets — each of which is 
divided into a Header section and Body section.  

Use the following steps to create a new Standard Driver Worksheet: 
1. From the Studio development environment, select the Comm tab, located below the Workspace pane. 
2. In the Workspace pane, expand the Drivers folder and right-click the SRTP subfolder.  
3. When the pop-up menu displays, select the Insert option: 

 

Inserting a New Worksheet 
 

 

 Tip:  
To optimize communication and ensure better system performance, you must tie the tags in different 
driver worksheets to the events that trigger communication between each tag group and the period in 
which each tag group must be read or written. Also, we recommend configuring the communication 
addresses in sequential blocks to improve performance. 
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The <drivername>.drv dialog displays (similar to the following figure): 

 

SRTP Driver Worksheet 

 
4.   Use the following information to complete the Station, Header, and Address fields on this worksheet.  

 

# Note:  
This publication explains how to configure the Station, Header, and Address fields. All of the other 
parameters on the Driver worksheet are standard for all communication drivers. Consult the product’s 
Technical Reference Manual for information about configuring these standard entries.  

 

� Station field: Use this field to specify the PLC IP Address.  Valid values are any string or tag (no default). 
� Header field (Default value is %I): Use this field to define 

– The type of variable that can be read from or written to the host 
– A reference to the initial address  

The Header parameter must comply with the following syntax: 

<Type> (for example, %R) 

Where <Type> is the register type (%I=Discrete Input, %Q=Discrete Output, %M=Discrete Internal, 
%T=Discrete Temporary, %AI=Analog Input, %AQ=Analog Output, %R=Internal Registers, %G=Global 
Genius Data). 
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After you edit the Header field, Studio verifies whether the syntax is valid. If the syntax is incorrect, Studio 
automatically puts the %I default value in the field. 

The following table lists all of the data types and address ranges that are valid for the Header field:  
 

Header Field Information 

Data Types Syntax Samples Valid Range of  
Initial Addresses  

Comments 

%I %I 1 to 512 Discrete Input 

%Q %Q 1 to 512 Discrete Output 

%M %M 1 to 1024 Discrete Internal 

%T %T 1 to 256 Discrete Temporary 

%AI %AI 1 to 1024 Analog Input 

%AQ %AQ 1 to 256 Analog Output 

%R %R 1 to 9999 Internal Registers 

%G %G 1 to 1280 Global Genius Data (Boolean) 
 

� Address field: Use this field to associate each tag in the worksheet to its address in the device. You type 
the tag’s name into the Tag Name column and the tag’s device address into the Address column, to enable 
the tag to read from and write to an address on the device. (See the following table for the valid Address 
configuration information.) 

  
Address Configuration Sample 

Variable on the Host Header Field  Address Field  
%I0001 %I 1 
%I0010 %I 10 
%I0512 %I 512 
%Q0512 %Q 512 
%M1020 %M 1020 
%T200 %T 200 
%AI060 %AI 60 
%AI060 (bit 0) %AI 60.0 
%AQ080 %AQ 80 
%AQ080 (bit 3) %AQ 80.3 
%R0100 %R 100 
%R0100 (bit 7) %R 100.7 
%R09900 %R 9900 
%G0500 %G 500 
%G0001 %G 1 
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Entries in Address field must comply with the following syntax: 

– For Discrete Input, Discrete Output, Discrete Internal, Discrete Temporary, and Global Genius Data: 
<Address> 

– For Analog Input, Analog Output, and Internal Registers: 
<Format><Address>.<Bit> 

Where: 
* Format is the data format of the value to be read from/written to the device (optional parameter).  

Type: 
F to treat the values as Floats (double words) (for example, F5) 
None to treat the values as Integer (for example, 3) 

* Address is the address of the value to be read from/written to the device (for example, 25). 
* Bit is the bit number (from 0–15) from the Word address (for example, 10.2). This parameter is 

optional. 
 
 

Â Caution:  
� You must not configure a range of addresses that is greater than the maximum block size 

(data buffer length) supported by each PLC (64 bytes per driver worksheet) within the same 
worksheet. 

� You can read bit values from the %AI, %AQ, and %R registers, but you cannot write bit values 
to these registers.  

 
 

Configuring the MAIN Driver Worksheet 
When you add the SRTP driver to your application, Studio automatically adds a MAIN DRIVER SHEET to the 
driver folder, as shown: 
  

 

MAIN Driver Worksheet 
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The MAIN Driver Worksheet (similar to the following figure) enables you to easily associate Studio tags to 
addresses in the PLC: 

 

SRTP MAIN Driver Worksheet 

Most of the MAIN DRIVER SHEET parameters are standard for all drivers. Instructions for configuring these 
standard parameters are provided in the Studio Technical Reference Manual. This section provides instructions 
for configuring the Station and I/O Address parameters, which are specific to this driver:  
� Station: Type the PLC Address (ID number). 
� I/O Address: Type the address of each register in the PLC using the following syntax: 

– For Discrete Input, Discrete Output, Discrete Internal, Discrete Temporary, and Global Genius Data: 
<Type>:<Address> 

– For Analog Input, Analog Output, and Internal Registers: 
<Type>:<Format><Address>.<Bit> 

Where: 

* Type is the register type ((%I=Discrete Input, %Q=Discrete Output, %M=Discrete Internal, 
%T=Discrete Temporary, %AI=Analog Input, %AQ=Analog Output, %R=Internal Registers, 
%G=Global Genius Data).  

* Format is the data format of the value to be read from/written to the device (optional parameter).  
Type: 
F to treat the values as Floats (double words) (for example, %R:F20) 
None to treat the values as Integer (for example, R:15) 

* Address is the address of the value to be read from/written to the device. (For example, %R:100) 
* Bit is the bit number (from 0–15) from the Word address (for example, %R:10.2)  

This parameter is optional. 
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Configuring the Device 

To configure the PLC device, you must set the PLC IP Address using the PLC programming tools. 

Executing the Driver  

After adding the SRTP driver to a project, Studio sets the project to execute the driver automatically when you 
start the run-time environment.  

To verify that the driver run-time task is enabled and will start correctly, perform the following steps: 
� Select Project → Status from the main menu bar. 

The Project Status dialog displays: 

 

Project Status Dialog 

2.   Verify that the Driver Runtime task is set to Automatic. 

� If the setting is correct, click OK to close the dialog.  
� If the Driver Runtime task is set to Manual, select the Driver Runtime line. When the Startup button becomes 

active, click the button to toggle the Startup mode to Automatic.  
3.   Click OK to close the Project Status dialog.  

4.   Start the application to run the driver. 
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Troubleshooting 

If the SRTP driver fails to communicate with the device, the tags configured for the Read Status or Write Status fields 
will receive an error code. Use this error code and the following table to identify what kind of failure occurred.  

 
Error Code Description Possible Causes Procedure to Solve 

0 OK  Communication without problems Not Required. 

1 Invalid Header Invalid Header provided in the worksheet 
Header field 

Type a valid header into the Header field (see page 8  for 
configuration instructions). 

2 Invalid Address Invalid Address provided in the worksheet 
Address field  

� If you used a tag in the Header field, verify that the tag 
value is valid for the configured addresses. 

� If you are not using tags, and you changed the Header 
after configuring the addresses, the addresses may be 
invalid for the new Header.  

3 Invalid Station Invalid Station provided in the worksheet 
Station field 

Type a valid station into the Station field (see page 8  for 
configuration instructions). 

20 Invalid Command Received answer with invalid command code Check the connection to be sure the device communicates 
using the SRTP protocol. 

21 Invalid Block Size Offset specified in worksheet is too big and the 
message cannot be framed. 

Change the offsets or create a new worksheet. 

22 Failed to allocate 
memory 

Insufficient memory for driver buffers � Check the buffer configuration and try to reduce the buffer 
size (see page 6). 

� Increase the computer or HMI memory. 

23 Invalid Answer Problems with communication medium Check all cables, hubs, and routers. 

24 Invalid unsolicited 
message 

Received an unsolicited message, not 
supported by the driver 

Check all devices connected on the network to ensure there 
are no devices sending messages using a different protocol 
from the same port. 

26 Error connecting Cannot establish a TCP/IP connection to the 
device 

� Check the device to be sure it is connected to the 
network. 

� Check the IP Address specified in the worksheet Station 
field to be sure it matches the device’s IP Address. 

-15 Timeout waiting to 
start a message 

� Disconnected cables 
� PLC turned off, or in stop or error mode 
� Wrong station number 
� Wrong RTS/CTS configuration settings 

� Check the cable wiring. 
� Check the PLC state; it must be RUN. 
� Check the station number.  
� Check the configuration. See the Studio Technical 

Reference Manual for valid RTS/CTS settings. 

-17 Timeout between rx 
chars 

� PLC in stop or error mode 
� Wrong station number 
� Wrong parity 
� Wrong RTS/CTS configuration settings 

� Check the PLC state; it must be RUN. 
� Check the station number. 
� Check the configuration. 
� Check the configuration.  See the Studio Technical 

Reference Manual for valid RTS/CTS settings. 
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 Tip:  
You can verify communication status using the Studio development environment Output window (LogWin 
module). To establish an event log for Field Read Commands, Field Write Commands, and Serial Communication 
right-click in the Output window. When the pop-up menu displays, select the option to set the log events.  

If you are testing a Windows CE target, you can enable the log at the unit (Tools → LogWin) and verify the 
celog.txt file was created at the target unit.  

 

If you cannot establish communication with the PLC, try to establish communication between the PLC 
Programming Tool and the PLC. Quite frequently, communication is not possible because you have a hardware 
or cable problem, or a PLC configuration error. After successfully establishing communication between the 
device’s Programming Tool and the PLC, you can retest the supervisory driver. 
To test communication with Studio, we recommend using the sample application provided rather than your new 
application. 
If you must contact us for Technical Support, please have the following information available: 
� Operating System (type and version): To find this information, select Tools → System Information.  
� Project Information: To find this information, select Project → Status. 
� Driver Version and Communication Log: Displays in the Studio Output window when the driver is running. 
� Device Model and Boards: Consult the hardware manufacturer’s documentation for this information.  
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Sample Application 

You will find a sample application in the /COMMUNICATION EXAMPLES/SRTP directory. We strongly recommend 
that you use this sample application to test the SRTP driver before configuring your own customized application, 
for the following reasons: 
� To better understand the information provided in the section of this document. 
� To verify that your configuration is working satisfactorily. 
� To certify that the hardware used in the test (device, adapter, cable, and PC) is working satisfactorily before 

you start configuring your own, customized applications. 
 

# Note:  
This application sample is not available for all drivers.  

 
Use the following procedure to perform the test: 
1. Configure the device’s communication parameters using the manufacturer’s documentation. 
2. Open and execute the sample application. 
3. Execute the Viewer module in Studio to display information about the driver communication. 
 

 Tip:  
You can use the sample application screen as the maintenance screen for your custom applications. 
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Revision History 

Version By Date Description of changes 

1.00 José L. Teodoro 16-Jan-2002 First driver version 

1.01 Eric Vigiani 22-Apr-2003 Modified maximum block size for the MAIN DRIVER SHEET 
Fixed bug when reading bits. 

1.02 Eric Vigiani 26-Nov-2003 Included the data format to %AI,  %AQ and %R 
 
 


