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Converting from EZware-500 to EBPro
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This document provides the guidelines for converting an application from EZware-500 to EBPro. This 
document provides details about the upgrade process and materials needed.

Solution
Maple Systems offers several innovative HMIs that provide an upgrade path for existing applications. For 
simple applications, the transition process is fairly smooth. For more complicated applications, the 
process may require additional efforts and considerations.

Communications Cable: 
If RS-232 serial communications is used on the application and the upgrade is from an HMI500 model to 
new HMI, the pin out of the COM port has changed. Pins 2 and 3 have been swapped and the gender 
has been changed. Purchasing a new serial cable for the application is recommended. However, a null-
modem adapter and gender-changer can be used on the existing 500 Series cable instead (part number 
2117-0910). 
If RS-485 serial communication is used, insert a gender-changer on the HMI end of the existing 500 
Series cable (part number 2117-0903). A null-modem is not required.

NOTE: Due to programming restrictions, applications must be converted from EZware-500 to EZware-
5000 before converting the project to EBPro.  For optimum success, use the most current version of 
programming software.

When choosing a new model, keep the following in mind:

 Choose a new model with the same screen dimensions as the old unit.

 The current 4.3” HMIs will fit in the same cutout as the old 4.3” HMIs. 

 The current 7” HMIs will fit in the same cutout as the old 5.6” and 7” HMIs. The 7” HMIs 
combined with a cutout adapter (contact Maple Systems for the appropriate part number) are 
recommended to replace the old 8” HMIs, or a new 10” can be used by enlarging the cutout. 

 The current 10” HMIs are smaller than the old 10” HMIs; it is recommended to use a new 10” 
HMI and contact Maple Systems about the cutout adapter, or use a current 12” HMI and 
enlarge the panel cutout. 
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1. EZware-500 Steps
1.1. Download EZware-500, located here: 

https://www.maplesystems.com/supportcenter/softwaredownloads.htm It is the last item 
under Legacy Software.

1.2. After installing EZware-500, connect the configuration 7431-0098A cable.
1.3. Power the HMI (24VDC, 2A).
1.4. In Windows, select Start Menu -> All Programs -> Maple Systems -> EZware-500 -> 

EasyManager.

1.5. Select the COM port that the configuration cable is connected to and select Project 
Download/Upload.

1.6. Click the Upload button to begin transferring the HMI project to your PC.
1.7. Save the file as an .EOB file format with a name and location of your choosing.

Next is the translation from EZware-500 into EZware-5000. This is done with the Translation utility, an 
application conversion tool for EZware-500 projects built into the EZware-5000 software. It will convert 
most of the major features of the EZware-500 project into an EZware-5000 project. Doing this requires at 
least EZware-5000 Version 4.10 or newer.

https://www.maplesystems.com/supportcenter/softwaredownloads.htm
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2. EZware-5000 Steps
2.1. Download and install EZware-5000, located here: 

https://www.maplesystems.com/supportcenter/softwaredownloads.htm. It is located in the 
Legacy Software section.

2.2. Open EZware-5000 and open the Translate tool, located in Tools -> Translate HMI 500 
Project… 

2.3. Select the EZware-500 project .EOB file for the HMI500 EOB file using the Browse… 
button in the HMI500 EOB file section.

2.4. Enter a name and select a file location to store the converted EZware-5000 project file 
using the Browse… button in the HMI5000 project section. 

2.5. Leave the “Use HMI500 ASCII font files” and the “Use the most suitable font size 
automatically” boxes checked.

NOTE: The EZware-500 configuration software uses proprietary fonts that must be 
replaced with a Windows TrueType font. EZware-5000 installs three TrueType fonts into 
the Windows > Fonts folder that closely resemble the fonts used in EZware-500 (HMI 500 
16p, HMI 500 24p, HMI 500 8p). Select Use HMI500 ASCII font files to use these fonts. 
If you choose to use another Windows TrueType font (by un-checking Use HMI500 ASCII 
font files), additional alteration may be required after you have converted your project. We 

https://www.maplesystems.com/supportcenter/softwaredownloads.htm
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recommend using Calibri, if available. Otherwise, another san serif font like Helvetica is 
recommended.

NOTE: You can allow EasyBuilder-5000 to automatically adjust the font size by selecting 
Use the most suitable font size automatically. If you uncheck this box, you can click on the 
Font Size Table button, which allows you to customize the transition size of the fonts from 
EasyBuilder-500 to EasyBuilder-5000 projects. This gives you maximum flexibility in 
deciding which font and which sizes you would like to use. For the Calibri font, we 
recommend those items as shown in the table below.

2.6. Check the Delete “Direct Window” objects which are triggered with LB9060~9069, 9080, 
9081 box.

2.7. Click the Translate button and wait for the operation to complete. Depending on the size 
and complexity of the project, this may take several seconds. When Succeeded is 
displayed, click the Exit button.

2.8. Open the newly translated project by going to File -> Open… and selecting the EZware-
5000 project in the location specified.
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Conversion Utility Checklist
Due to differences in EZware-500 and EZware-5000, most features convert directly, but some need 
additional attention to convert properly. Here is a list of those features:
 Window Names: The window names in the Window No. Tree are not converted. In EZware-

5000, the window names revert to the window numbers (i.e., Window_10, Window_11, etc.).
 Numeric Input objects: Numeric Input objects in EZware-500 use pre-made keypad objects, 

typically on Windows 50-54. Windows 50 and 51 have keypads with a view area which shows 
the current number being input into the keypad. In EZware-500, this register is tagged to 
LW9073. EZware-5000 uses a new location for the view area: LW9150. Therefore, as part of 
your conversion, you must edit Windows 50 and 51 and change the AD0 (ASCII Display Object 
0) Read Address from LW9073 to LW9150.

 Number keypad with Maximum and Minimum Limits: These keypads also have two Numeric 
Display objects that show the Minimum and Maximum limits as set in the Numeric Input Register. 
These convert erroneously to 32-bit signed. Change the data format to 32-bit float for both of these 
registers.

 Security Password feature: In EZware-500, this feature was screen-based and supported only 
three level security passwords. In EZware-5000, the security feature is greatly enhanced with six 
levels and twelve unique user passwords. Due to suggestions we have received from customers, 
we have changed the security feature from screen-based to object-based, making it more versatile. 
Therefore, the security feature in EZware-500 is not converted into EZware-5000. If you use the 
security feature, you must manually add this feature into the converted project.

NOTE: Go to the Support Center on our website and view the educational video entitled, 
“Security Features of the Maple Systems HMI5000 Series.” You can also download a Security 
sample project from the “Sample Projects” link.

 Message Board: The Message Board Window Type is not implemented in EZware-5000.
 Alarms: The Alarm Scan and Event Log are combined into the Alarm (Event) Log object in 

EZware-5000.
 Trend Display: The scroll controls are now built into the Trend Display, so separate Set Word 

objects to scroll the display are no longer required. The scroll controls can be turned on and off in 
the Trend Display properties. If the Hold control was used, it must be enabled in the Trend 
Display properties. Scale graphics next to the Trend Display may need to be realigned.

 Event Display: The scroll controls are now built into the Event Display, so separate Set Word 
objects to scroll the display are no longer required. Display items will need to be reconfigured in 
the Event Display properties.

 Recipe Transfer object: This feature has been combined into a new feature in EZware-5000 
called the Data Transfer (Trigger-based) object. The feature should work properly after 
conversion.

 Tag Library: Although tags are supported in EZware-5000, any tag library that was created in 
EZware-500 is not converted over into the new software. This is because the tag library is stripped 
from the project file when compiled in EZware-500 to minimize the project file size. You can 
export the Tag file in your EZware-500 project to a CSV file. But before you import it into the 
EZware-5000 software, you must edit the CSV file and add a new column (Column B) which lists 



     Phone: 425/745-3229 • Fax: 425/745-3429 • Email: support@maplesystems.com • www.maplesystems.com
0907-5102 Page 6 of 8 Rev. 04, 06/11/2021

the communications driver that you assigned to each tag. Please see our Technical Note 5035 
entitled “Converting HMI500 Series Tags to the HMI5000 Series.”

 Label Library: Labels are imported into the EZware-5000 software as long as an object that 
references the label exists. Otherwise, you can export the Label Library in EZware-500 into a CSV 
file, modify the CSV file to fit the new format used in EZware-5000, and then import the CSV 
into your converted file.

 System Tags: Some system tags in reserved local memory have been changed in EZware-5000 
and may not map correctly after conversion.

 PLC Communications Drivers: The EZware-5000 software supports many more communication 
protocols than EZware-500. Note that some communication protocol drivers used in EZware-500 
do not translate correctly into EZware-5000. These include:
Baldor MINT
Compumotor 6k Series
Copley Xenus
Galil DMC-Series
IIS (Industrial Indexing Systems)
Keyence KV
Moeller (not included in EZware-5000)
Siemens Simatic TI505
Yaskawa Memobus

 Macros: On very early models of the HMI500 series, Macros were not saved within the HMI in a 
text format and are not uploaded with the rest of the project out of the HMI. If there are compiling 
errors due to missing Macros, those must be recreated from scratch or from the original project file 
if available.

 Popup Windows: In EZware-500, a popup window could have a Function Key configured to 
“Change window” back to the window that called the popup window, closing the popup window 
at the same time. In EZware-5000, a Function Key on a popup must be configured to go to a 
different full screen window (or to “Close” the window) or the popup window won’t close.
For Function Keys configured to open popup windows, open the Properties and make sure that 
“Close this popup window when parent window is closed” is checked. Uncheck it only if you 
prefer the popup window to stay on the screen.

For the final step of conversion, you may skip converting from EZware-5000 to EZwarePlus and instead 
go directly from EZware-5000 to EBPro. 
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3. EBPro Steps
3.1. Using the Compress utility in EZware-5000, compress the EZware-5000 project. This 

utility is found in Tools -> Compress/Uncompress. This will create a new file with the 
same name as the project, but with the file extension .CMP. This is required to be sure that 
all the dependencies, such as library files, are transferred to EBPro.

3.2. Download and install EBPro, located here: 
https://www.maplesystems.com/supportcenter/softwaredownloads.htm.  The latest version 
is the first item in the table.

3.3. Open EBPro and open the Compress/Uncompress utility, located in File -> 
Compress/Uncompress. Select the compressed file, file extension .CMP. Also set a 
destination to uncompress to. Finally, click the Uncompressing button.

https://www.maplesystems.com/supportcenter/softwaredownloads.htm
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NOTE: Beginning with EZwarePlus v2.00, the project file extension was changed to *.emtp. It will 
still open *.mtp files, but saves them as *.emtp files.


